Browser Support

To run the maxView Storage Manager GUI, each system in your storage space must be running one of these Web browsers:

  • Microsoft® Internet Explorer® 8, 9, 10, 11 or newer
  • Google® Chrome™ 32 or newer
  • Mozilla Firefox® 24 or newer

Email Address (optional):

Did this topic answer your question?

Strongly Agree
Agree
Neutral
Disagree
Strongly Disagree

Comments: